This site is now 100% read-only, and retired.

XML logo

Madwifi - Lenny - D-link.
Posted by Grimnar on Wed 19 Dec 2007 at 22:16
Tags: none.
So, Im at a friends house and trying to install a wlan desktop card. This is a D-link DWA-547 desktop adapter. Just installed the madwifi package using apt-get and module-assistant. Followed the instructions on http://madwifi.org/wiki/UserDocs/Distro/Debian/MadWifi But it just does not work. So I will paste some interesting details: lspci:
02:02.0 Network controller: Atheros Communications, Inc. Unknown device 0023 (rev 01)
dmesg:
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
wlan: 0.8.4.2 (0.9.3.2)
ath_pci: 0.9.4.5 (0.9.3.2)
ath_pci: driver unloaded

ath_pci: no version for "struct_module" found: kernel tainted.
ath_pci: no version magic, tainting kernel.
ath_pci: 0.9.4.5 (0.9.3.2)
iwconfig:
lo        no wireless extensions.

eth0      no wireless extensions.
uname -a
Linux debian 2.6.22-3-686 #1 SMP Mon Nov 12 08:32:57 UTC 2007 i686 GNU/Linu
Now, what can I do about this? We tried a few weeks ago using a Broadcom card using ndiswrapper and hopefully we will never try that again, that was a real pain to configure, and finally not work anyway. So we re-installed debian and bought a new card in hope of a better solution. And so far that has not happend:/ -Andreas

 

Comments on this Entry

Re: Madwifi - Lenny - D-link.
Posted by Anonymous (85.221.xx.xx) on Wed 19 Dec 2007 at 22:25
Okay, I just found this link; http://www.gentoo-wiki.com/HARDWARE_dwa-547 but I have no clue on how to make it work on debian. Never used SVN before and Im really afraid of breaking stuff.

[ Parent ]